package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)requesterDN=(?<requesterDN.ou>.+?)`)
var str = `requesterDN=\"ou=*,uid=*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}