$re = '/(?<!\S)[A-Za-z]++(?![:;.])/';
$str = 'float a bbc 10';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);