import re
regex = re.compile(r"(?<!x)(?=(?:[._ –-]*\d){9})\d{2,}[._ –-]*\d{2,}[._ –-]*\d{2,}", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("x123456789\n"
"X123456789\n"
"x123-456-789\n"
"X123-456-789\n"
"123-456-789\n"
"ordernumber123-456-789\n"
"order number123-456789\n"
"order number 123456789\n"
"123-456789\n"
"123456789\n"
"ordernumber-x123456787\n"
"ordernumber-123456787\n"
"ordernumber - 123456789\n"
"ordernumber #123456789\n"
"ordernumber *anysplcharacter*123456789\n"
"ordernumber !@#$%^&123456789\n"
"123456789*@*#123456789\n"
"social security number 123-456-789\n"
"ordernumber !@#$%^&x123456789\n"
"123456789\n"
"#@%#$%#$123456789#$%#$^$#\n\n"
"123456789\n"
"123 45 6789\n"
"123-45-6789\n"
"123-45-6789\n"
"123 – 45 – 6789\n"
"123.45.6789\n"
"123_45_6789\n"
"123 456 789\n"
"123-456-789\n"
"123 – 456 – 789\n"
"123.456.789\n"
"123_456_789\n"
"1234 56 789\n"
"1234-56-789\n"
"1234 – 56 – 789\n"
"1234.56.789\n"
"1234_56_789\n"
"12 345 6789\n"
"12-345-6789\n"
"12 – 345 – 6789\n"
"12.345.6789\n"
"12_345_6789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")