package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Status\s*:\s*(\w+)`)
var str = `Status : PASS some words
Status : FAIL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}