$re = '/(\b(?=[^_])[\w]+)/m';
$str = 'just _checking any _string.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);