re = /^(?:[\w.]+,{1}(?:STR|INT|REAL){1},{1}(\s*|$))+$/m
str = 'positive:
Component,STR,YoungGenUse,STR,YoungGenMax,STR,OldGenUse,INT,OldGenMax,INT,PermGenUse,INT,PermGenMax,INT,MajCollCnt,INT,MinCollDur,REAL,MinCollCnt,INT,
negative:
Component,STR,YoungGenUse,STR,YoungGenMax,TEST,OldGenUse,INT,OldGenMax,INT,PermGenUse,INT,PermGenMax,INT,MajCollCnt,INT,MinCollDur,REAL,MinCollCnt,INT,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end