$re = '/\buniversal\b.*\bjap(?:an)?\b/';
$str = 'universal studio japan
universal japan
univerally japan
universal jap
something universal japan is here
Something is universal. I have something about japan written here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);