package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z0-9_]+@(.+?):|https?:\/\/(.+?)\/`)
var str = `git@company-name.com:/company-name/repo.git
https://company-name.com/company-name/repo.git
http://company-name.com/company-name/repo.git
anyuser@company-name.com:/company-name/repo.git`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}