package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)INIT \d{3}-\d{3}-\d{3}-\d{3}`)
var str = `INIT 255-255-255-255`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}