package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(log-)?(entry\s\d+)`)
var str = `entry 200
log-entry 200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}