package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)-(\d{4}/\d\d/\d\d)-(\d[\d,]*)-`)
var str = `Tracking code: 1160685022- Date: 2022/07/26- Time: 21:02- Last 4 digits: None- First 4 digits: None- Amount: 350 thousand Dollars- To Paypal
222826-2022/07/26-32,700,000-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}