package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\H+[A-Z]\H*\b`)
var str = `Massive Innovation InterFace`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}