const regex = /^(src-env-package)_v([0-9]+\..*)\.([0-9]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(src-env-package)_v([0-9]+\\..*)\\.([0-9]+)$', 'gm')
const str = `src-env-package_v1.0.1.18`;
const subst = `$1 $2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);