package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|,)HAB($|,)`)
var str = `HAB
DHAB,RAB,DAB
HAB,RAB,DAB
RAB,HAB,
RAB,HAB,DAB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}