# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\S)(?<text>(?<comment>(?<open>[#;]+)(?:[^\S\r\n]*)(?<value>.+))|(?<section>(?<open>\[)(?:\s*)(?<value>[^\]]*\S+)(?:[^\S\r\n]*)(?<close>\]))|(?<entry>(?<key>[^=\r\n\[\]]*\S)(?:[^\S\r\n]*)(?<delimiter>:|=)(?:[^\S\r\n]*)(?<value>[^#;\r\n]*))|(?<undefined>.+))(?<=\S)|(?<linebreaker>\r\n|\n)|(?<whitespace>[^\S\r\n]+)"
test_str = ("; Comment above the section\n"
"Key0=Value0\n"
"[Section 1]\n"
"Key=Value \n"
" [EmptySection]\n"
"Dummy text\n"
";Commented Key=Value\n"
";The following empty lines are ignored\n"
";\n"
" # \n"
" \n"
" [ Section 2 ]#Comment after [section]; \n"
" Key 1 = Value 1\n"
" Key2 = Value 2 and [text in square brackets]\n"
" EmptyKey= \n"
"[];Noname section ignored\n"
" [ Section2 ] Dummy text after section\n"
" Key3 =Value 3 (symbols [;] are included) \n"
" #Key4 = Value 4 has been commented \n\n"
"Dummy text before section [ Sectionnum3 ] \n"
" Key 5 = Value 5 \n"
" Key6 =Value6 ")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.