$re = '/\w*ph\w*/';
$str = 'phone find phill phdas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);