#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^.*?(?=----------|$)"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"----------" & @CRLF & _
"User 1 said the following:" & @CRLF & _
"" & @CRLF & _
"Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"----------" & @CRLF & _
"User 2 said the following:" & @CRLF & _
"" & @CRLF & _
"Magna fermentum iaculis eu non diam phasellus vestibulum lorem. Lectus quam id leo in vitae turpis massa sed elementum. Ut consequat semper viverra nam libero. Libero justo laoreet sit amet cursus sit amet." & @CRLF & _
"What I want"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")