import re
regex = re.compile(r"(?:\G(?!^)|\()[^)(]*+\K\(([^)(]*)\)", flags=re.MULTILINE)
test_str = ("Record ID\n"
"What is the best food? (choice=Nachos)\n"
"What is the best food? (choice=Tacos (big bent nachos))\n"
"What is the best food? (choice=Chips with stuff) \n"
"Complete?\n\n"
"So ((this) one (has) (many) (inside)) (none here) (but (here) and (here))\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)