using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(box(?:es)?|bxs|bags?))\1([a-zA-Z]+)";
string input = @"boxes
bags
boxesapple
boxapple
bagapple
bagsapple";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}