$re = '/^(?=.{8,20}$)(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])(?=[^0-9]*[0-9])(?=[^?!:;]*[?!:;])(?:([\w\d*?!:;])(?!\1))+$/m';
$str = 'testabcde1A
testatA!est1
thistestek1A!a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);