$re = '/([\r\n]+)\{\W*name|\{\W*name/m';
$str = 'Single-line events:
{\\"name\\":\\"\\",\\"\\":,\\"severity\\":\\"info\\",\\"time\\":,\\"host\\":\\"\\",\\"hostname\\":\\"\\",\\"\\":\\"\\",\\"\\":\\"UNKNOWN CORRELATION\\",\\"userId\\":\\"UNKNOWN USER\\",\\"moduleName\\":\\"\\",\\"\\":\\"a\\",\\"client\\":\\"AgentDesktop\\",\\"type\\":\\"application\\",\\"msg\\":\\"\\",\\"\\":\\"\\"}
{\\"name\\":\\"\\",\\"level\\":30,\\"\\":\\"info\\",\\"time\\":,\\"host\\":\\"\\",\\"hostname\\":\\"\\",\\"\\":\\"\\",\\"clientCorrelationId\\":\\"\\",\\"userId\\":\\"UNKNOWN
Multi-line events:
{\\"name\\":\\"\\",\\"\\":,\\"severity\\":\\"info\\",\\"time\\":,\\"host\\":\\"\\",\\"hostname\\":\\"\\",\\"\\":\\"\\",\\"\\":\\"UNKNOWN CORRELATION\\",\\"userId\\":\\"UNKNOWN USER\\",\\"moduleName\\":\\"\\",\\"\\":\\"a\\",\\"client\\":\\"AgentDesktop\\",\\"type\\":\\"application\\",\\"msg\\":\\"\\",\\"\\":\\"\\"}{\\"name\\":\\"\\",\\"level\\":30,\\"\\":\\"info\\",\\"time\\":,\\"host\\":\\"\\",\\"hostname\\":\\"\\",\\"\\":\\"\\",\\"clientCorrelationId\\":\\"\\",\\"userId\\":\\"UNKNOWN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);