$re = '/^[A-Z0-9]{6}-[A-Z0-9]{6}-[A-Z0-9]{6}$/m';
$str = 'ABCD12-DEFG34-HIJK89
ABCD12-DEFG34-HIJK891';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);