$re = '/subs\.\d+\.apps\.\d+$/';
$str = 'subs.0.subs.0.apps.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);