const regex = /(?!(\.|;|,)\s*)[A-ZÀ-Ý]{1}[a-zà-ÿ:-]+\s*(?:[a-zA-ZÀ-ÿ:-]\s*)+(\.|!|\?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(\\.|;|,)\\s*)[A-ZÀ-Ý]{1}[a-zà-ÿ:-]+\\s*(?:[a-zA-ZÀ-ÿ:-]\\s*)+(\\.|!|\\?)', 'gm')
const str = `ABBAGNANO, N. Dicionário de Filosofia. São Paulo: Martins Fontes, 1998.
ABBAGNANO, N. Dicionário de Filosofia. 5. ed. rev. e amp. São Paulo: Martins Fontes, 2007.
ALLEN, B.; KIM, K.-S.; Person and context in information seeking: Interactions between cognitive and task variables. The New Review of Information Behaviour Research, v. 2, p. 1–16, 2001.
ALMEIDA, M.; SOUZA, R.; FONSECA, F. Semantics in the Semantic Web: A Critical Evaluation. Knowledge Organization, Berlin, v. 38, No.3, pp. 187 – 203, maio/jun. 2011.
ARBOIT, A. E.; BUFREM, L. S.; KOBASHI, N. Y. A Institucionalização da Ciência da Informação no Brasil sob a Ótica da Evolução Quantitativa dos Cursos de Graduação na Área. Informação & Sociedade: Estudos, João Pessoa, v.21, n.1, p. 145-158, jan./abr. 2011.
ARISTÓTELES. Órganon. Bauru - SP: Edipro, 2005.
ARMENGAUD, F. A Pragmática. São Paulo: Parábola Editorial, 2006.
ASSOCIAÇÃO BRASILEIRA DE NORMAS TÉCNICAS (ABNT). NBR 10520: Informação e documentação – Citações em documentos – Apresentação. Rio de Janeiro: ABNT, 2002.
BENVENISTE, É. Problemas de linguística geral. São Paulo: Ed. Nacional; EDUSP, 1976. Volume I.
BERNERS-LEE, T. Semantic Web Concepts. 2005a. Disponível em: <http://www.w3.org/2005/Talks/0517-boit-tbl>. Acesso em: 25 set. 2014
BERNERS-LEE, T. Web for real people. 2005b. Disponível em <http://www.w3.org/2005/Talks/0511-keynote-tbl/ >. Acesso em: 25 set. 2014.
BERNERS-LEE, T.; CAILLIAU, R. WorldWideWeb: Proposal for a HyperText Project. 1990. Disponível em: < http://www.w3.org/Proposal.html >. Acesso em: 13 out. 2014.
BERNERS-LEE, T.; HENDLER, J.; LASSILA, O. The semantic web: a new form of web content that is meaningful to computers will unleash a revolution of new possibilities. New York: Scientific American, 2001. Disponível em: <http://www.sciam.com/2001/050lissue/0501berners-lee.html>. Acesso em: 13 out. 2014.
BLAIR, D. C. Information Retrieval and the Philosophy of Language. Annual Review of Information Science and Tecchnology, v. 37, pp. 3-50, Medford, 2003.
BLAIR, D. C. Wittgenstein, Language and Information: Back to the Rough Ground! Dordrecht: Springer, 2006.
BONFIM, M. E. Recuperação de Documentos Texto Usando Um Modelo Probabilístico Estendido. Piracicaba: UNIMEP, 2006. 131 f. Dissertação (Mestrado em Ciência da Computação). Mestrado em Ciência da Computação. Universidade Metodista de Piracicaba, 2006.
BORLUND, P. The Concept of Relevance in IR. Journal of the American Society for Information Science and Technology, v.54, p. 913-925, 2003.
BORST, W. N. Construction of engineering ontologies. Tese (Doutorado em Information and Knowledge Systems). University of Tweenty – Centre for Telematica and Information Technology, Enschede, Nederland, 1997.
BOUNDLESS. Boundless Psychology. 201X. Disponível em < https://www.boundless.com/psychology/textbooks/boundless-psychology-textbook/ > Acesso em: 13 ago. 2014.
BRATT, S. Semantic Web, and Other Technologies to Watch. 2008. Disponível em < http://www.w3.org/2008/Talks/1009-bratt-W3CSemTech/Overview.html > Acesso em: 13 ago. 2014.
BRÉAL, M. Semantics: studies in the science of meaning. New York: Henry Holt & Company, 1900.
BRICKLEY, D.; MILLER, L. FOAF Vocabulary Specification 0.9. 2007. Disponível em < http://xmlns.com/foaf/spec/20070524.html > Acesso em: 17 maio 2015.
BRITISH LIBRARY. Sample Data. Disponível em <http://www.bl.uk/bibliographic/ datasamples.html>. Acesso em: 12 dez. 2014.
BRUYNE, P. de, HERMAN, J., SCHOUTHEETE, M. de. Dinâmica da pesquisa em ciências sociais. Rio de Janeiro: Francisco Alves, 1977.
BUFREM, L. S, et al. Modelizando práticas para a socialização de informações- a construção de saberes no ensino superior. Perspectivas em Ciência da Informação, Belo Horizonte, v.15, n.2, p.22-41, maio/ago. 2010.
BUNGE, M. Teoria e realidade. São Paulo, Perspectiva, 1974.
CABRÉ, M. T. La terminologia: representación y comunicación: elementos para una teoría de base comunicativa y otros artículos. Barcelona: IULA/Universitat Pompeu Fabra, 1999.
CABRÉ, M. T. La terminología: teoría, metodología, aplicaciones. Barcelona: Antártida/Empúries, 1993.
CANÇADO, M. Manual de Semântica: noções básicas e exercícios. Belo Horizonte: UFMG, 2008.
CAPURRO, R. What is information science for? A philosophical reflection. in: Pertti Vakkari, Blaise Cronin Eds.: Conceptions of Library and Information Science. Historical, empirical and theoretical perspectives, London: Taylor Graham 1992, pp. 82-98.
CARDOSO, O. N. P. Recuperação de Informação. Infocomp, Lavras, v. 2, n. 1, p. 33-38, 2000.
CARSTAIRS-MCCARTHY, A. Origins of Language. In: ARONOFF, M.; RESS-MILLER, J. The Handbook of Linguistics. Oxford: Blackwell Publishers Ltd, 2008. p. 1-18.
CASE, D. O. Looking for Information: A Survey of Research on Information Seeking, Needs, and Behavior. London: Academic Press, 2007.
CHEN, P. P-S. The Entity-Relationship Model-Toward a Unified View of Data. ACM Transactions on Database Systems, v.1, n.1, p. 9-36, 1976. Disponível em: <http://www.csc.lsu.edu/news/erd.pdf>. Acesso em 23 mar. 2014.
CINTRA, A. et al. Para Entender as Linguagens Documentárias. São Paulo: Polis, 1994.
CORTINA, A. O Príncipe de Maquiavel e seus leitores: uma investigação sobre o processo de leitura. São Paulo: Editora UNESP, 2000.
DAHLBERG, I. Teoria do conceito. Ciência da Informação, Rio de Janeiro, v. 7, n. 2, p. 101-107, 1978. Disponível em: <http://revista.ibict.br/index.php/ciinf/article/view/ 1680/1286>. Acesso em 23 mar. 2014.
DE MOOR, A. Patterns for the Pragmatic Web, In: DAU, F.; MUGNIER, M.-L.; STUMME, G. International Conference on Conceptual Structures. Lecture Notes in Computer Science, v. 3596, p. 1-18, 2005.
DE MOOR, A.; KEELER, M.; RICHMOND, G. Towards a pragmatic web, In: UTA, Priss et al. Conceptual Structures: Integration and Interfaces. Lecture Notes in Computer Science, v. 2393, p. 235-249, 2002. Disponível em < http://www.cspeirce.com/menu/library/aboutcsp/richmond/web.pdf >. Acesso em 23 mar. 2014.
DI MAIO, P. The Missing Pragmatic Link in the Semantic Web. Business Intelligence Advisory Service Executive Update. v. 8, n. 7, 2008.
ECO, U. Lector in Fabula: la cooperación interpretativa en el texto narrativo. Barcelona: Lumen, 1987
ECO, U. O conceito de texto. São Paulo: T. A. Q. /EDUSP, 1984.
ECO, U. Obra aberta: forma e indeterminação nas poéticas contemporâneas. São Paulo: Perspectiva, 1988.
ECO, U. Os limites da interpretação. São Paulo: Pioneira, 2000.
EDMONDS, B. The Pragmatic Roots of Context. In: PROC. OF THE 2ND INTERNATIONAL AND INTERDISCIPLINARY CONFERENCE ON MODELING AND USING CONTEXT. Berlin; Heidelberg; New York, v. 1688, 1999. Anais… v. 1688, p. 119-132, 1999.
FLORIDI, L. On the intrinsic value of information objects and the infosphere. Ethics and Information Technology, v. 4, n. 4, p 287-304, 2002.
FRANCELIN, M. M. Ordem dos conceitos na organização da informação e do conhecimento. Tese (Doutorado em Ciência da Informação). Universidade de São Paulo – PPGCI, São Paulo, 2010.
FREGE, G. Lógica e Filosofia da Linguagem. São Paulo: EDUSP, 2009.
GARSHOL, L. M. Living with topic maps and RDF. 2003. Disponível em <http://www.ontopia.net/topicmaps/materials/tmrdf.html> Acesso em: 08 abr. 2014.
GESSA, N. Test Cases for RDF/TM Interoperability. 2005. Disponível em <http://tesi.fabio.web.cs.unibo.it/view/RDFTM/TestCases>. Acesso em 14 dez. 2014.
GERSTING, J. L. Fundamentos Matemáticos para a Ciência da Computação. Rio de Janeiro: LTC, 1995.
GONZÁLEZ DE GOMEZ, M. N.; GRACIOSO, L. de S. Ciência da informação e a ação comunicativa no cenário Web. In: ENCONTRO NACIONAL DE PESQUISA EM CIÊNCIA DA INFORMAÇÃO, v.8, 2007, Salvador. Anais..., v.8, 2007.
GONZÁLEZ, J. A. M. et al. De los tesauros a los topic maps: nuevo estándar para la representación y la organización de la información. Enc. Bibli: R. Eletr. Bibliotecon. Ci. Inf., Florianópolis, n.18, 2º sem. 2004.
GRACIOSO, L. de S. Justificação e a ação de informação no contexto da pragmática virtual. Liinc em Revista, Rio de Janeiro, v.6, n.2, p. 286- 300, set. 2010.
GREIMAS, A. J., COURTÉS, J. Dicionário de semiótica. São Paulo: Cultrix, 1983.
GRUBER, T. A translation approach to portable ontologies. Knowledge Acquisition, v.5, n.2, p. 199-220, 1993.
GRUBER, T. SKRB Mailing List, 1994.
GUARINO, N. Formal Ontology in Information Systems. 1998. Disponível em: <http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.29.1776&rep=rep1&type=pdf>. Acesso em 23 mar. 2014.
HJØRLAND, B. Concept theory. Journal of the American Society for Information Science and Technology, v.60, n.8, p.1519-1536, 2009.
HJØRLAND, B. Domain analysis in information science: eleven approaches traditional as well as innovative. Journal of Documentation, v.58, n.4, 2002, p. 422-462, 2002.
HJØRLAND, B. Is classification necessary after google? Journal of Documentation. 2012, 68(3), 299-317.
HJØRLAND, B. The phrase “information storage and retrieval” (IS&R): A historical note. Journal of the Association for Information Science and Technology. 2014. Disponível em: <http://www.curis.ku.dk/ws/files/94411548/IS_R_Final.docx>. Acesso em: 14 dez. 2014.
HJØRLAND, B. What is Knowledge Organization (KO)? Knowledge Organization, v.35, n.2/3, p.86-101, 2008.
INGWERSEN, P. Information Retrieval Interaction. London: Taylor Graham, 1992.
INGWERSEN, P.; JÄRVELIN, K. The turn: integration of information seeking and retrieval in context. Dordrecht, The Netherlands: Springer, 2005.
INTERNATIONAL ORGANIZATION FOR STANDARDIZATION (ISO). ISO/IEC 13250:2003: Information technology -- SGML applications -- Topic maps. Genebra, 2003.
INTERNATIONAL ORGANIZATION FOR STANDARDIZATION (ISO). ISO/IEC 13250-2:2006: Information technology -- Topic Maps -- Part 2: Data model. Genebra, 2006.
INTERNATIONAL ORGANIZATION FOR STANDARDIZATION (ISO). ISO/IEC 13250-3:2013: Information technology -- Topic Maps -- Part 3: XML syntax. Genebra, 2013.
JAPIASSÚ, H.; MARCONDES, D. Dicionário Básico de Filosofia. Rio de Janeiro: Zahar, 2006.
JÄRVELIN, K.; VAKKARI, P. The Evolution of Library and Information Science 1965-85: A Content Analysis of Journal Articles. In: VAKKARI, P.; CRONIN, B., Conceptions of Library and Information Science: Historical, empirical and theoretical perspectives. London, UK: Taylor Graham, 1992. p. 109-125.
JULIEN, H.; MICHELS, D. Intra-individual information behaviour in daily life. Information Processing and Management, v. 40, p. 547-562, 2004.
KEMP, D. A. Relevance, Pertinence and Information System Development. Information Storage and Retrieval, V. 10, N. 2, pp. 37-47, 1974.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}