$re = '/,(?!\d+])/';
$str = 'on,"two","three[r,6]",four[6,5],"five,sex"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);