import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\$(\\d{1,3}(?:,\\d{1,3})*(?:\\.\\d{1,2})?)\\s*-\\s*\\$(\\d{1,3}(?:,\\d{1,3})*(?:\\.\\d{1,2})?)\\s*per\\s+(?:annum|hour)\\s*$";
final String string = "$80,000,000,000.00 - $90,000,000,000.00 per annum\n"
+ "$80,000,000 - $90,000,000 per annum\n"
+ "$80,000 - $90,000 per annum\n"
+ "$20 - $24.99 per hour\n"
+ " $20 - $24.99 per hour\n"
+ "$20 - $24.99 per hour\n"
+ " $20.00 - $24.99 per hour\n"
+ " $20.00 - $24.99 per day\n"
+ " $111,120.00 - $11,124.99 per week\n"
+ " $111,222,120.00 - $111,111,124.99 per months";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}