re = /.*(foo(?:(?!foo|bar).)+bar)/m
str = 'some text here foo bar word foo bar word foo word bar word foo word bar foo word bar more text here'
# Print the match result
str.match(re) do |match|
puts match.to_s
end