$re = '/}\R.*\R.*}(\R|$)/';
$str = 'está no fim da linha -> }
qualquer texto, \\" blablá etc
linha } <- não está no final da linha, deve pular
está no fim da linha, mas tem mais de uma linha entre esse e o primeiro }
asdasdasasdsaeeeee
{
aaaaaa
adsasdassdasdfff } <- não está no final da linha, não deve pegar
qualquer texto, \\" blablá etc
asdasdasasdsa
fim da linha -> }
apenas uma linha, \\", á´bcetc
esse vai pegar }';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);