# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(X(-?\d+(?:\.\d+)?))?\s*(Y(-?\d+(?:\.\d+)?))?"
test_str = ("N14 X411 Y279.05\n"
"N15 G2 X33 Y280.4 I.001 J4.00\n"
"N16 G1 X408 Y280.4\n"
"N17 G2 X402.3 Y280.09 I-3 J2.65\n"
"N18 G1 X402.3 Y280.09\n"
"N19 G2 X402.09 Y285.79 I2.7 J2.95\n"
"N20 G1 X402.09 Y285.79\n"
"N3 G40 Y6000\n"
"N3 G40 X-6000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.