$re = '/abc{2,5}/m';
$str = 'ab
abc
abcc
abccc
abcccc
abccccc
abcccccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);