re = /(?<=[a-z\d])([A-Z$][A-Za-z]*(?: +\S+?)*):/m
str = '[[\'Company OverviewCompany: HowSector: SoftwareYear Founded: 2010One Sentence Pitch: Easily give and request low-quality feedback with your team to achieve more togetherUniversity Affiliation(s): Duke$ Raised: $240,000Investors: Friends & familyTraction to Date: 10% of monthly active users (MAU) are also active weekly\'], [[\'Company OverviewCompany: GrubSector: SoftwareYear Founded: 2018One Sentence Pitch: Find food you likeUniversity Affiliation(s): Stanford$ Raised: $340,000Investors: Friends & familyTraction to Date: 40% of monthly active users (MAU) are also active weekly\']]]
'
subst = ', \\1:'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result