$re = '~\bId:\b\.?\s*\K\w+~m';
$str = 'Id:003182736371hdu test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);