re = /#{1,6}.+/
str = '
# Clean-er ReactJS Code - Conditional Rendering
## TL;DR
Move render conditions into appropriately named variables. Abstract the condition logic into a function. This makes the render function code a lot easier to understand, refactor, reuse, test, and think about.
## Introduction
Conditional rendering is when a logical operator determines what will be rendered. The following code is from the examples in the official ReactJS documentation. It is one of the simplest examples of conditional rendering that I can think of.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end