package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<protocol>\w+)(?<slashes>:\/\/)((?<user>\w+)((?<userColon>:)(?<password>\w+))?(?<at>@))?(?<host>[^:\/]+)((?<portColon>:)(?<port>\d+))?(?<path>\/[^#?]*)?(?<query>\?[^#]+)?((?<octothorpe>#)(?<fragment>.+))?`)
var str = `https://@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}