$re = '/.+?(?=\h\()/';
$str = 'Дом на Вельяминовской (г. Москва, (м. Семеновская) ул. Вельяминовская, 27)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);