$re = '/\d+(?!\d| dollars)/m';
$str = '100dollars
100 dollars
50 dollars
50 eur
500 dollars
500 pesos';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);