re = /^(?!^admin$).*$/m
str = 'admin
superadmin
administrator
someusername123!@#$%^&^&*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end