use strict;
my $str = '5758 6128 370 kWh 1 370 kWh 11,93 kWh 12/07/2019 01/08/2019 Mês kWh Dt.Pgto. Valor 06/2019 355 17/06/2019 343,79 NOTA FISCAL/CONTA DE ENERGIA ELÉTRICA N° 085.976.711 - SÉRIE B Emitida em 03/07/2019 05/2019 332 14/05/2019 306,84 Produto Valor Valor Base Aliq. 04/2019 415 29/05/2019 378,67 Descrição Un. Consumo Unitário Total Cálc. ICMS 03/2019 308 14/05/2019 269,81 ENERGIA ELETRICA CONSUMO kWh 370 0,787324 291,31 291,31 29,00% 02/2019 347 26/04/2019 305,09 ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00% 01/2019 341 11/03/2019 324,39 12/2018 301 26/12/2018 287,83 5758 6128 370 kWh 1 370 kWh 11,93 kWh 12/07/2019 01/08/2019 Mês kWh Dt.Pgto. Valor 06/2019 355 17/06/2019 343,79 NOTA FISCAL/CONTA DE ENERGIA ELÉTRICA N° 085.976.711 - SÉRIE B Emitida em 03/07/2019 05/2019 332 14/05/2019 306,84 Produto Valor Valor Base Aliq. 04/2019 415 29/05/2019 378,67 Descrição Un. Consumo Unitário Total Cálc. ICMS 03/2019 308 14/05/2019 269,81 ENERGIA ELETRICA CONSUMO kWh 370 0,787324 291,31 291,31 29,00% 02/2019 347 26/04/2019 305,09 ENERGIA CONS. B.AMARELA kWh 0,54 0,54 29,00% 01/2019 341 11/03/2019 324,39 12/2018 301 26/12/2018 287,83';
my $regex = qr/ENERGIA ELETRICA CONSUMO.*(?=%)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}