#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(uk:\d+,\d+,\w,\w+,\w+)"
Local $sString = "ro:2581,1309531682152,A,Place,Page,me:2642,1310989368864,A,Place,Page,uk:2556,1309267095061,A,Place,Page,me:2642,1310989380238,D,Place,Page,me:2642,1334659643627,D,Place,Page,ro:3562,1378721526696,A,Place,Page,uk:1319,1309337246675,D,Place,Page,ro:2581,1379500694666,D,Place,Page,uk:1319,1309337246675,A,Place,Page"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")