package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(http|https|ftp)\://[a-zA-Z0-9\-\.&%\$#\=~]+`)
var str = `https://google.fr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}