const regex = /(?:<StudentName>\sjoe[^< ]*).*?\n.*?<StudentFamily>([^<]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<StudentName>\\sjoe[^< ]*).*?\\n.*?<StudentFamily>([^<]*)', 'gmi')
const str = `<School>
<Class>
<StudentID> 1 </StudentID>
<StudentName> Joe </StudentName>
<StudentFamily> Brown </StudentFamily>
</Class>
<Class>
<StudentID> 2 </StudentID>
<StudentName> Michel </StudentName>
<StudentFamily> Adams </StudentFamily>
</Class>
<Class>
<StudentID> 3 </StudentID>
<StudentName> Joel </StudentName>
<StudentFamily> Thompson </StudentFamily>
</Class>
</School>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}