const regex = /https?:\/\/.*\/([^.]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/.*\\\/([^.]*)', 'g')
const str = `http://ecx.images-amazon.com/images/I/41zdz1zsG9L.SR38,50.jpg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);