$re = '/^([0-1][0-9]|2[0-3]):([0-5][0-9])$/mi';
$str = '10:30
11:45
12:00
23:20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);