re = /at .*\.(\w*) \(.*js\/(\w*)\/(?!logger)(\w*)\..{2,4}:(\d*:\d*)\)/
str = 'Error
at getCallerTag (http://localhost:4577/js/base/logger.js:31:17)
at Object.logIt (http://localhost:4577/js/base/logger.js:25:18)
at Object.debug (http://localhost:4577/js/base/logger.js:11:12)
at HTMLInputElement.updateFileNames (http://localhost:4577/js/modules/pdf.js:12:11)
at HTMLInputElement.n.event.dispatch (http://localhost:4577/vendor/js/jquery-2.2.3.min.js:3:7537)
at HTMLInputElement.r.handle (http://localhost:4577/vendor/js/jquery-2.2.3.min.js:3:5620)
> match[1] = \'updateFileNames\', match[2] = \'modules\', match[3] = \'pdf\', match[4] = \'12:11\'
Error
at getCallerTag (http://localhost:4577/js/base/logger.js:31:17)
at Object.logIt (http://localhost:4577/js/base/logger.js:25:18)
at Object.debug (http://localhost:4577/js/base/logger.js:11:12)
at Object.Foo (http://localhost:4577/js/base/components.js:75:21)
at HTMLInputElement.n.event.dispatch (http://localhost:4577/vendor/js/jquery-2.2.3.min.js:3:7537)
at HTMLInputElement.r.handle (http://localhost:4577/vendor/js/jquery-2.2.3.min.js:3:5620)
> match[1] = \'Foo\', match[2] = \'base\', match[3] = \'components\', match[4] = \'75:21\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end