re = /\/(?!(register|login)?$)/m
str = '/register
/login
/
/foobar
/register-foobar
/loginbarfoo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end