using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?!.*\/\/)([a-zA-Z-\/]+)$";
string input = @"/this/is/an/url/path
/this/is/an/url/path/
/this/is/an/url/path!
/this/is/an/url/path@
/this-is-an//url/path";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}