#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<\/?SOAP[^<>]+?>"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:wsse="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:wsu="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-utility-1.0.xsd">" & @CRLF & _
" <SOAP-ENV:Header></SOAP-ENV:Header>" & @CRLF & _
" <SOAP-ENV:Body>" & @CRLF & _
" <VisionDataExchange>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)