$re = '/(\d+)d|\s+|(\d+)h|\s+|(\d+)m/i';
$str = '13d 20h 32m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);