$re = '/\bsize(?= )/';
$str = '<font size=4>This is size in text</font>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);