re = /^(?:[^ ]*\ ){4}([^ ]*)/
str = 'The quick brown fox jumps over the lazy dog'
# Print the match result
str.match(re) do |match|
puts match.to_s
end